using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<script[^>]*>[^\0]*?<\/script>";
string substitution = @"";
string input = @"<!doctype html>
<html>
<head>
<title>Testing</title>
<script src=""htttp://...""></script>
</head>
<body>
<img />
<!-- and so on -->
</body>
</html>
<script>
function f(){
if (2 < 5) {
// ...
};
};
</script>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}