// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<script[^>]*>[^\0]*?<\/script>").unwrap();
let string = "<!doctype html>
<html>
<head>
<title>Testing</title>
<script src=\"htttp://...\"></script>
</head>
<body>
<img />
<!-- and so on -->
</body>
</html>
<script>
function f(){
if (2 < 5) {
// ...
};
};
</script>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}