# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<script[^>]*>[^\0]*?<\/script>"
test_str = ("<!doctype html>\n"
"<html>\n"
" <head>\n"
" <title>Testing</title>\n"
" <script src=\"htttp://...\"></script>\n"
" </head>\n"
" <body>\n"
" <img />\n"
" <!-- and so on -->\n"
" </body>\n"
"</html>\n"
"<script>\n"
" function f(){\n"
" if (2 < 5) {\n"
" // ...\n"
" };\n"
" };\n"
"</script>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.