package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<script[^>]*>[^\0]*?<\/script>`)
var str = `<!doctype html>
<html>
<head>
<title>Testing</title>
<script src="htttp://..."></script>
</head>
<body>
<img />
<!-- and so on -->
</body>
</html>
<script>
function f(){
if (2 < 5) {
// ...
};
};
</script>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}