# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<big( +\w* *= *\"\w*" *)+>\s*<b>.*<\\/b>\s*<\\/big>//isU;t' <<< "<big class = \"value\" class2 = \"dd\">
<b>
текÑÑ‚
</b>
</big>"