using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<big( +\w* *= *\""\w*"" *)+>\s*<b>.*<\/b>\s*<\/big>";
string substitution = @"";
string input = @"<big class = ""value"" class2 = ""dd"">
<b>
текÑÑ‚
</b>
</big>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}