# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<big( +\w* *= *\"\w*\" *)+>\s*<b>.*<\/b>\s*<\/big>"
test_str = ("<big class = \"value\" class2 = \"dd\">\n"
" <b>\n"
" текÑÑ‚\n"
" </b>\n"
"</big>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.IGNORECASE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.