// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?isU)<big( +\w* *= *\"\w*" *)+>\s*<b>.*<\/b>\s*<\/big>"#).unwrap();
let string = "<big class = \"value\" class2 = \"dd\">
<b>
текÑÑ‚
</b>
</big>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}