const regex = /<big( +\w* *= *\"\w*" *)+>\s*<b>.*<\/b>\s*<\/big>/is;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<big( +\\w* *= *\\"\\w*" *)+>\\s*<b>.*<\\\/b>\\s*<\\\/big>', 'is')
const str = `<big class = "value" class2 = "dd">
<b>
текÑÑ‚
</b>
</big>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);