package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?isU)<big( +\w* *= *\"\w*" *)+>\s*<b>.*<\/b>\s*<\/big>`)
var str = []byte(`<big class = "value" class2 = "dd">
<b>
текÑÑ‚
</b>
</big>`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}