use strict;
my $str = '<big class = "value" class2 = "dd">
<b>
текÑÑ‚
</b>
</big>';
my $regex = qr/<big( +\w* *= *\"\w*" *)+>\s*<b>.*<\/b>\s*<\/big>/isp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";