re = /<big( +\w* *= *\"\w*" *)+>\s*<b>.*<\/b>\s*<\/big>/i
str = '<big class = "value" class2 = "dd">
<b>
текÑÑ‚
</b>
</big>'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result