import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<big( +\\w* *= *\\\"\\w*\" *)+>\\s*<b>.*<\\/b>\\s*<\\/big>";
final String string = "<big class = \"value\" class2 = \"dd\">\n"
+ " <b>\n"
+ " текÑÑ‚\n"
+ " </b>\n"
+ "</big>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}