# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\+?\d{3} ?\d{3} ?\d{3} ?\d{3}$//gm;t' <<< "+420 000 000 000
+420000000000
420 000 000 000
420000000000"