import Foundation
let pattern = #"^\+?\d{3} ?\d{3} ?\d{3} ?\d{3}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+420 000 000 000
+420000000000
420 000 000 000
420000000000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)