use strict;
my $str = '+420 000 000 000
+420000000000
420 000 000 000
420000000000';
my $regex = qr/^\+?\d{3} ?\d{3} ?\d{3} ?\d{3}$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";