import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+?\\d{3} ?\\d{3} ?\\d{3} ?\\d{3}$";
final String string = "+420 000 000 000\n"
+ "+420000000000\n"
+ "420 000 000 000\n"
+ "420000000000";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}