// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+?\d{3} ?\d{3} ?\d{3} ?\d{3}$").unwrap();
let string = "+420 000 000 000
+420000000000
420 000 000 000
420000000000";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}