const regex = /^\+?\d{3} ?\d{3} ?\d{3} ?\d{3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+?\\d{3} ?\\d{3} ?\\d{3} ?\\d{3}$', 'gm')
const str = `+420 000 000 000
+420000000000
420 000 000 000
420000000000`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);