re = /^\+?\d{3} ?\d{3} ?\d{3} ?\d{3}$/m
str = '+420 000 000 000
+420000000000
420 000 000 000
420000000000'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result