using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+?\d{3} ?\d{3} ?\d{3} ?\d{3}$";
string substitution = @"";
string input = @"+420 000 000 000
+420000000000
420 000 000 000
420000000000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}