$re = '/^\+?\d{3} ?\d{3} ?\d{3} ?\d{3}$/m';
$str = '+420 000 000 000
+420000000000
420 000 000 000
420000000000';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;