#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\+?\d{3} ?\d{3} ?\d{3} ?\d{3}$"
Local $sString = "+420 000 000 000" & @CRLF & _
"+420000000000" & @CRLF & _
"420 000 000 000" & @CRLF & _
"420000000000"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)