#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\[)([^\]]*)(\])"
Local $sString = "I don't [wanna] be a bus [driver] all my [life]"
Local $sSubst = "<b>$2</b>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)