re = /(\[)([^\]]*)(\])/
str = 'I don\'t [wanna] be a bus [driver] all my [life]'
subst = '<b>$2</b>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result