import re
regex = re.compile(r"(\[)([^\]]*)(\])")
test_str = "I don't [wanna] be a bus [driver] all my [life]"
subst = "<b>$2</b>"
result = regex.sub(subst, test_str)
if result:
print(result)