import Foundation
let pattern = #"(\[)([^\]]*)(\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I don't [wanna] be a bus [driver] all my [life]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<b>$2</b>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)