package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[)([^\]]*)(\])`)
var str = `I don't [wanna] be a bus [driver] all my [life]`
var substitution = "<b>$2</b>"
fmt.Println(re.ReplaceAllString(str, substitution))
}