const regex = /(\[)([^\]]*)(\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[)([^\\]]*)(\\])', 'g')
const str = `I don't [wanna] be a bus [driver] all my [life]`;
const subst = `<b>$2</b>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);