# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([\s\S]*?)<h3>(.*?)<\\/h3>/$1<h1>$2<\/h1>/;t' <<< "<html>
<table></table>
<h3>test</h3>
<h3>wofl</h3>
<h1>test</h1>
</html>"