$re = '/^([\s\S]*?)<h3>(.*?)<\/h3>/';
$str = '<html>
<table></table>
<h3>test</h3>
<h3>wofl</h3>
<h1>test</h1>
</html>';
$subst = "$1<h1>$2</h1>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;