#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^([\s\S]*?)<h3>(.*?)<\/h3>"
Local $sString = "<html>" & @CRLF & _
"<table></table>" & @CRLF & _
"<h3>test</h3>" & @CRLF & _
"<h3>wofl</h3>" & @CRLF & _
"<h1>test</h1>" & @CRLF & _
"</html>"
Local $sSubst = "$1<h1>$2</h1>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)