re = /^([\s\S]*?)<h3>(.*?)<\/h3>/
str = '<html>
<table></table>
<h3>test</h3>
<h3>wofl</h3>
<h1>test</h1>
</html>'
subst = '$1<h1>$2</h1>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result