import Foundation
let pattern = #"^([\s\S]*?)<h3>(.*?)<\/h3>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<html>
<table></table>
<h3>test</h3>
<h3>wofl</h3>
<h1>test</h1>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1<h1>$2</h1>"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}