use strict;
my $str = '<html>
<table></table>
<h3>test</h3>
<h3>wofl</h3>
<h1>test</h1>
</html>';
my $regex = qr/^([\s\S]*?)<h3>(.*?)<\/h3>/p;
my $subst = '$1<h1>$2</h1>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";