package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([\s\S]*?)<h3>(.*?)<\/h3>`)
var str = []byte(`<html>
<table></table>
<h3>test</h3>
<h3>wofl</h3>
<h1>test</h1>
</html>`)
var substitution = []byte("$1<h1>$2</h1>")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}