const regex = /^([\s\S]*?)<h3>(.*?)<\/h3>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\s\\S]*?)<h3>(.*?)<\\\/h3>', '')
const str = `<html>
<table></table>
<h3>test</h3>
<h3>wofl</h3>
<h1>test</h1>
</html>`;
const subst = `$1<h1>$2</h1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);