using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\s\S]*?)<h3>(.*?)<\/h3>";
string substitution = @"$1<h1>$2</h1>";
string input = @"<html>
<table></table>
<h3>test</h3>
<h3>wofl</h3>
<h1>test</h1>
</html>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}