import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\s\\S]*?)<h3>(.*?)<\\/h3>";
final String string = "<html>\n"
+ "<table></table>\n"
+ "<h3>test</h3>\n"
+ "<h3>wofl</h3>\n"
+ "<h1>test</h1>\n"
+ "</html>";
final String subst = "$1<h1>$2</h1>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}