# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([\s\S]*?)<h3>(.*?)<\/h3>"
test_str = ("<html>\n"
"<table></table>\n"
"<h3>test</h3>\n"
"<h3>wofl</h3>\n"
"<h1>test</h1>\n"
"</html>")
subst = "$1<h1>$2</h1>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.