# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+),(\w+),(\w+),(\w+)/<Item>\n <Product type="\1" name="\2" price="\3" quantity="\4">\n<\/Item>/g;t' <<< "food,apple,10,10
sweets,candy,20,20"