package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+),(\w+),(\w+),(\w+)`)
var str = `food,apple,10,10
sweets,candy,20,20`
var substitution = "<Item>\n <Product type="\1" name="\2" price="\3" quantity="\4">\n</Item>"
fmt.Println(re.ReplaceAllString(str, substitution))
}