// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+),(\w+),(\w+),(\w+)").unwrap();
let string = "food,apple,10,10
sweets,candy,20,20";
let substitution = "<Item>\\n <Product type=\"\\1\" name=\"\\2\" price=\"\\3\" quantity=\"\\4\">\\n</Item>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}