$re = '/(\w+),(\w+),(\w+),(\w+)/';
$str = 'food,apple,10,10
sweets,candy,20,20';
$subst = "<Item>\n <Product type=\"\1\" name=\"\2\" price=\"\3\" quantity=\"\4\">\n</Item>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;