import re
regex = re.compile(r"(\w+),(\w+),(\w+),(\w+)")
test_str = ("food,apple,10,10 \n"
"sweets,candy,20,20")
subst = "<Item>\\n <Product type=\"\\1\" name=\"\\2\" price=\"\\3\" quantity=\"\\4\">\\n</Item>"
result = regex.sub(subst, test_str)
if result:
print(result)