#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\w+),(\w+),(\w+),(\w+)"
Local $sString = "food,apple,10,10 " & @CRLF & _
"sweets,candy,20,20"
Local $sSubst = "<Item>\n <Product type="\1" name="\2" price="\3" quantity="\4">\n</Item>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)