import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+),(\\w+),(\\w+),(\\w+)";
final String string = "food,apple,10,10 \n"
+ "sweets,candy,20,20";
final String subst = "<Item>\\n <Product type=\"\\1\" name=\"\\2\" price=\"\\3\" quantity=\"\\4\">\\n</Item>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}