# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Текст1(?s:.*?)Текстn//g;t' <<< "------
Текст1
Текст2
....
Текстn
------"