import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Текст1(?s:.*?)Текстn";
final String string = "------\n"
+ "Текст1\n"
+ "Текст2\n"
+ "....\n"
+ "Текстn\n"
+ "------";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}