package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Текст1(?s:.*?)Текстn`)
var str = `------
Текст1
Текст2
....
Текстn
------`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}